Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: WinCC Verbindung mit OPC

  1. #1
    Registriert seit
    09.04.2015
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe dem Variablenhaushalt von WinCC 7.3 eine Verbindung hinzugefügt und über den OPC-Item-Manager entsprechende Variablen eingefügt.

    Die Verbindung scheint laut Explorer offenbar auch zu funktionieren.

    In der Graphics Runtime erhalte ich alerdings über einen Online TableControl teilweise nur den Wert "0 u." und im Zusatand der Datenanbindung die Meldung "Variablenwert ungültig, oder keine Verbindung"
    Hat jemand eine Idee woran das liegen kann, bzw. was das 0 u. bedeutet?

    Ein Verbindungsproblem zwischen beiden Servern schließe ich aus, da ich auf dem "WinCC-Server" mithilfe des OPC-Scouts 10 die entsprechenden Variablen mit plausiblen Werten beobachten kann.

    Vielen Dank für eure Hilfen und Viele Grüße
    Geändert von tt-scorpion (13.04.2015 um 15:13 Uhr)
    Zitieren Zitieren WinCC Verbindung mit OPC  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Das Online Table Control dient üblicherweise dazu, um Variablenwerte aus dem Taglogging Archiv anzuzeigen. Dafür musst du aber das Taglogging und ein passendes Archiv konfigurieren.

    Wenn du den aktuellen Online-Status eines Variablenwertes sehen möchtest, kannst du ganz einfach ein EA-Feld verwenden.

  3. #3
    Registriert seit
    20.01.2009
    Beiträge
    190
    Danke
    32
    Erhielt 15 Danke für 14 Beiträge

    Standard

    Im WinCCExplorer unter Extras kann der Verbindungsstatus überprüft werden.
    Status muß "OK" sein.

    Im Variablenhaushalt können die Variablen überprüft werden.
    - Spalte "Wert" einblenden
    - Runtime starten
    - in der Spalte Wert stehen die aktuellen Werte
    (ich glaube, nur die aktuell benötigten/angeforderte Werte)

  4. #4
    tt-scorpion ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vielen Dank für eure Antworten,

    der Verbindungsstatus im WinCC Explorer wird mit OK angezeigt.

    Im Variablenhaushalt steht bei den Werten aber nur ???.
    Ich habe keine Idee woran das liegen kann. Wie gesagt im Online Control Table (in der Graphic Runtime) kann ich folgende Meldung entnehmen "Variablenwert ungültig, oder keine Verbindung".

    Hat einer von euch noch eine Idee woran das liegen kann?

    Grüße

  5. #5
    Registriert seit
    20.01.2009
    Beiträge
    190
    Danke
    32
    Erhielt 15 Danke für 14 Beiträge

    Standard

    Ich habe selber noch keine OPC-Verbindung eingerichtet.

    Du kannst aber folgende Punkte prüfen:

    Im Variablenhaushalt beim OPC-Kanaltreiber rechtsklicken und Systemparameter anklicken.
    (OPC-Item-Manager)
    Dort kannst du deine Variablen suchen und vielleicht auch testen.

    Rechtsklick auf deine OPC-Verbindung und Verbindungsparameter anklicken.
    Auch hier gibt es eine Testfunktion.

    Ansonsten poste mal die ganzen Einstellungen,
    sowie die Eigenschaften einer Variable.

  6. #6
    Registriert seit
    20.01.2009
    Beiträge
    190
    Danke
    32
    Erhielt 15 Danke für 14 Beiträge

    Standard

    Hast du den Vorschlag vom Thomas schon probiert?
    (EA-Feld im Bild)

  7. #7
    tt-scorpion ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    E_A_Feld.JPGOPC_Scout.JPGOPC-Verbindung1.JPGTabelControl.JPGVariablenhaushalt.JPG

    Die Variablen habe ich mithilfe des Item Managers eingefügt.
    Leider habe ich das schon alles versucht! Bisher ohne Erfolg..

  8. #8
    tt-scorpion ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Verbindungen.JPG

    Hier noch ein Nachtrag

  9. #9
    Registriert seit
    20.01.2009
    Beiträge
    190
    Danke
    32
    Erhielt 15 Danke für 14 Beiträge

    Standard

    Es gibt 2 OPCServer?
    Cimetrics.BACnetOPCserver_1
    Cimetrics.BACnetOPCserver_2

    Die nicht funktionierenden Variablen sind vom Server2.
    Funktionieren denn die Variablen vom Server1?

    Du kannst im Variablenhaushalt noch die Spalten „QualityCode“ und „Variablenstatus“ einblenden und kontrollieren.

    Nachtrag:
    Bei den WinCC-Tools gibt es noch "ChannelDiagnosis"
    Geändert von hub (15.04.2015 um 15:01 Uhr)

  10. #10
    tt-scorpion ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    das mit den 2 OPC-Servern ist Richtig. Der *_1 ist allerdings noch nicht richtig Konfiguriert. Hier sind alle Variablen enthalten die ich vom OPC-Server benötige. Allerdings habe ich hier nach mehreren Updates (u.a. von WinCC) die Adressen des OPC Servers und der Variablen noch nicht angepasst. im *_2 wollte ich ein Kommunikationstest durchführen. D.h. es kommen von beiden keine Werte an. (wobei es bei _1 logisch ist)

    QualityCode und Variablenstatus enthält auch nur "???"
    die ChannelDiag hat mich auch nicht weiter gebracht!
    ChannelDiagnosis1.JPGChannelDiagnosis2.JPG

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 16.03.2011, 11:37
  2. Antworten: 1
    Letzter Beitrag: 08.02.2010, 14:15
  3. Verbindung zwischen LapView und WinCC über OPC klappt nicht!
    Von BorSven im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 03.12.2009, 20:12
  4. WinCC V5.2 und OPC Verbindung ändern..
    Von Tracer im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 15.05.2009, 21:53
  5. OPC Verbindung ausgefallen - WinCC
    Von acapulco im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 15.08.2008, 11:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •