Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Diagnose Fehler

  1. #1
    Registriert seit
    20.10.2005
    Beiträge
    62
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi, ich erhalte folgende Fehler. Was kann die Ursache sein?

    Hier ein Ausschnitt...

    Diagnosepuffer der Baugruppe CPU 315-2 DP

    Bestell-Nr./ Bezeichn. Komponente Ausgabestand
    6ES7 315-2AF03-0AB0 Hardware 2
    - - - Firmware V 1.2.1

    Baugruppenträger: 0
    Steckplatz: 2


    Ereignis 1 von 100: Ereignis-ID 16# 4304
    STOP durch PG-Stop-Bedienung oder wegen SFB 20 "STOP"
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP (intern)
    kommendes Ereignis
    06:31:13:975 28.01.94


    Ereignis 2 von 100: Ereignis-ID 16# 2943
    Peripherie-Zugriffsfehler, schreibend
    P-Bereich , Doppelwortzugriff, Zugriffsadresse: 0
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis
    06:31:13:974 28.01.94


    Ereignis 3 von 100: Ereignis-ID 16# 2942
    Peripherie-Zugriffsfehler, lesend
    P-Bereich , Wortzugriff, Zugriffsadresse: 0
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis
    06:31:13:973 28.01.94


    Ereignis 4 von 100: Ereignis-ID 16# 2943
    Peripherie-Zugriffsfehler, schreibend
    P-Bereich , Doppelwortzugriff, Zugriffsadresse: 4
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis
    06:31:13:971 28.01.94


    Ereignis 5 von 100: Ereignis-ID 16# 2943
    Peripherie-Zugriffsfehler, schreibend
    P-Bereich , Doppelwortzugriff, Zugriffsadresse: 0
    Angeforderter OB: Peripheriezugriffsfehler-OB (OB 122)
    Prioritätsklasse: 1
    externer Fehler, kommendes Ereignis
    06:31:13:971 28.01.94
    Zitieren Zitieren Diagnose Fehler  

  2. #2
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Du greifst schreibend auf ein Adresse im Peripheriebeiech zu, die nicht vorhanden ist.

    Geh mal auf den U-Stack und schau nach dem Quellcode.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  3. #3
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Wenn du die EA-Baugruppen erst später einbindest, kannst du den erwähnten Fehler OB in die CPU kopieren, dann geht diese nicht mehr in Stop.

    Gruß pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  4. #4
    Registriert seit
    20.10.2005
    Beiträge
    62
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenn ich unter Baugruppenzustand auf Stacks gehe zeigt er leider nur keine B-Stacks vorhanden. Cpu ist im STOP. U-Stacks und alle anderen Stacks sind nicht anwählbar.

  5. #5
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Es sieht so aus, als ob du auf PAW0 schreibst. Arbeitest du mit Registern für die Adressierung?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  6. #6
    Registriert seit
    20.10.2005
    Beiträge
    62
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Oh da fragen Sie mich zuviel bin SPS Neuling. Was ist den PAWO? Also um Ihnen halbwegs antworten zu können ich lade fest definierte Adressen über ein Anwender DB auf meine Funktionsblöcke in einem FB der durch ein DB im OB aufgerufen wird. Was mir aufgefallen ist nachden Sie sagten das ich schreiben auf eine Pheripherieadresse zugreife ist mir aufgefallen das die festen Adressen des AW-DB unterteilt sind in schriebende und lesende Adressen. Vielleicht habe ich solche eine Adresse verkehrt benutzt in meinem FB.

    mfg

  7. #7
    Registriert seit
    20.10.2005
    Beiträge
    62
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Mit PAW 0 meinten Sie sicher ob ich auf eine Adresse wie bei einer analog Baugruppe schreibe? Das kann auch möglich sein, da die Baugruppe (eine FM353) zum positionieren mir im Hardware Konfigurator mit folgenden Adressen angezeigt wird. Eingang Anfang 256 bis 271; Ausgang Anfang 256 bis 271. Das sind sicher die PAW Adressen. Aber was ich nicht so recht verstehe das Modul besitzt 4 digitale Ausgänge und 4 digitale Eingänge. Diese sind im AW-DB vordefiniert. Aber nicht als PAW sondern als feste Di und Do Adressen.

    Sorry aber bin neu auf dem Gebiet aber ich freue mich über jede Hilfe und lerne gern dazu.

    mfg

  8. #8
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Hmm,

    ich wundere mich über die fehlenden Einträge in den U-Stack. Bitte noch mal versuchen.

    Ansonsten mal unter Extras-Referenzdaten-Querverweise nach dem PAW xx suchen. Die müssen unter Filter extra mit in die Querverweise eingebunden werden.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  9. #9
    Registriert seit
    20.10.2005
    Beiträge
    62
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab bei Extras Referenzdaten Querverweise alle Filter aktiviert. U-Stacks kann ich wie gehabt noch nicht einsehen.

    mfg

  10. #10
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hast du in den Referenzdaten mal nach den PAW´s geguckt?
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

Ähnliche Themen

  1. Fehler duch Diagnose Repaiter?
    Von galoopie im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 17.08.2011, 13:36
  2. Antworten: 9
    Letzter Beitrag: 17.06.2011, 08:02
  3. Fehler- und Diagnose-OB
    Von Holger Levetzow im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 06.05.2010, 12:39
  4. S7 Graph keine Diagnose/Fehler in WinCC
    Von Pefida im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 01.10.2008, 07:42
  5. Diagnose Fehler
    Von titinparma im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 05.09.2007, 12:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •