Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: S7-1500 Ansteuerung eines Yaskawa-Umrichter mit Profinet

  1. #1
    Registriert seit
    23.10.2015
    Ort
    Hessen
    Beiträge
    51
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Forengemeinde,

    ich habe ein Problem mit der Ansteuerung eines Yaskawa-Umrichter mittels Profinet. Ich möchte den Umrichter mittels 6PZDs steuern und auslesen.
    Bei der Projektierung in TIA habe ich ein Verständnisproblem mit den Input- und Outputparametern.
    Wofür sind die im folgenden Screenshot dargestellten Parameter und was muss da eingestellt werden?

    screenshot.jpg
    Weise ich hier die IO-Adressen zu, obwohl die schon beim Telegramm eingetragen wurden?

    Ich finde es etwas verwirrend, da bei den Funktionen "DPRD_DAT" und "DPWR_DAT" der Parameter LADDR der HW-Kennung des Telegrammes entspricht, obwohl in der Hilfe steht das hier die HW_IO angegeben werden muss, was für mich eigentlich die jeweiligen IO Adressen des Gerätes sind. Ist zwar auf der einen Seite praktisch, da das Telegramm ja die entsprechenden IO-Adressen nutzt, nur verstehen tue ich das nicht wieso das hier im Grunde "anders", als im alten V5.5 wo direkt die IO-Adressen angegeben werden können, funktioniert. Kann mir bitte jemand erklären wo da der Sinn liegt?

    Weiter liefert mir die Funktion "DPRD_DAT" den Fehlercode, dass der Zielbereich zu klein ist. Ich vermute das hängt mit der unvollständigen Projektierung wie im Screenshot dargestellt zusammen obwohl ST 1+5PZDs für den Umrichter eingestellt ist.
    Könnte mir auch dabei jemand bitte auf die Sprünge helfen?


    Viele Grüße

    EK
    Zitieren Zitieren S7-1500 Ansteuerung eines Yaskawa-Umrichter mit Profinet  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.694
    Danke
    314
    Erhielt 1.506 Danke für 1.270 Beiträge

    Standard

    Also zu deinem Bild: Yaskawa Doku Studieren, da kann Siemens nichts dafür...

    Zu HW-IO:
    Das ist praktisch ein symbolisches LADDR, siehe Standardvariablentabelle, Systemkonstanten, da findest du dann PN-Name~Modulname.

    Zielbereich = Record ist falsch, z. B. möglicherweise optimierter Bereich mit Struct statt ARRA Of Word.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    SPS-EK (03.09.2016)

  4. #3
    SPS-EK ist offline Benutzer
    Themenstarter
    Registriert seit
    23.10.2015
    Ort
    Hessen
    Beiträge
    51
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo MSB,

    danke für deine Antwort.
    Nein, Siemens kann auch nichts dafür. Denen gebe ich auch nicht die Schuld.
    In der Yaskawa Doku von dem SI-EP-Modul(Profinet) steht nichts von den Parametern aus meinem Bild, daher die Frage was ich damit anfangen soll?

    Der Zielbereich ist einem optimierten Baustein aus einer Struktur in der wiederum eine Struktur aus 16 Bits für das PZD 1 und 5 weiteren Words für die restlichen 5 PZDs ist. Das funktioniert mit dem Siemens-Umrichter problemlos mit dem konstinenten Laden, nur beim Yaskawa-Umrichter zeigt mir die Funktion fehler an. Die Größen sind ja somit gleich. Kann das trotzdem Probleme entstehen lassen?
    Geändert von SPS-EK (13.08.2016 um 12:04 Uhr)

  5. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.694
    Danke
    314
    Erhielt 1.506 Danke für 1.270 Beiträge

    Standard

    In einer optimierten Struktur sind 16 Bit Structs kein Word, das kann so auch nicht bei einem Siemens Umrichter funktionieren.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    SPS-EK (03.09.2016)

  7. #5
    SPS-EK ist offline Benutzer
    Themenstarter
    Registriert seit
    23.10.2015
    Ort
    Hessen
    Beiträge
    51
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Oh stimmt, dadurch werden ja die einzelnen Bits jeweils als Byte abgelegt, korrekt?

    Grad nochmal nachgeschaut, ich lese die PZDs der Umrichter über ein FC ein und darin ist jeweils eine Struktur für senden und empfangen und darin eine Struktur für das PZD1 und 5 Words für die 5 weiteren PZDs.
    Daher wird es wohl funktionieren, da FCs ja keine IDBs mit optimierten Datenstrukturen haben oder denk ich hier auch falsch?

  8. #6
    SPS-EK ist offline Benutzer
    Themenstarter
    Registriert seit
    23.10.2015
    Ort
    Hessen
    Beiträge
    51
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Das Verbindungsproblem besteht noch immer, hat jemand noch ein Tipp was es sein könnte?

  9. #7
    SPS-EK ist offline Benutzer
    Themenstarter
    Registriert seit
    23.10.2015
    Ort
    Hessen
    Beiträge
    51
    Danke
    12
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Das Verbindungsproblem ist nach vielen Versuchen und umparametrierungen gelöst.

    Lösung: Man muss schon sagen, dass der Yaskawa Support relativ bescheiden ist entsprechend der Versions- und Herstellungsnummer des PN-Moduls die passenden GSDML-Dateien zu liefern.
    Nach drei verschiedenen Dateien, unter anderem welche die noch nicht von der Webpage geladen werden können und einer Anleitung die auch noch nicht veröffentlicht wurde, konnte endlich die Verbindung hergestellt werden.
    Tipp: Direkt den Support anschreiben und die Datei für die Versionen von "251 and greater" verlangen.

    Für mich persönlich, war es das letzte mal das Yaskawa-Umrichter eingesetzt wurden. Denn die Siemensumrichter lassen sich einfacher einstellen. Denn gerade die Parametrierung und Auswahl welche Parameter man miteinander verschalten muss um Rückspeisewerte und co zu erhalten ist hier sehr umständlich realisiert, wenn man mehr Werte als mit dem ST1 übertragen will, und selbst das wird noch mal Zeit benötigen bis das korrekt funktioniert. So genug ausgelassen

    Danke schonmal an MSB für die Hilfestellungen!

  10. #8
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.694
    Danke
    314
    Erhielt 1.506 Danke für 1.270 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke auf jeden Fall für die Rückmeldung, mit Yaskawa hatte ich bisher nur indirekt über die Tatsache zu tun, das die u.a. Motoman im Portfolio haben ...
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

Ähnliche Themen

  1. Yaskawa A1000 über PROFINET
    Von Niemandhatmichgesehn im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 14.08.2016, 18:59
  2. TIA Ansteuerung einer PowerMacs4000 mit S7-1500 über Profinet
    Von SPS-Praktikantin im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 02.08.2016, 12:39
  3. Antworten: 1
    Letzter Beitrag: 26.02.2016, 11:07
  4. Ansteuerung eines Motors mit Thermoschutz
    Von tofebto im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 13
    Letzter Beitrag: 17.05.2013, 08:52
  5. Ansteuerung eines Stromstossschalters mit Siemens Logo
    Von powerpuppe im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 27.04.2011, 20:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •