TIA Unterschiedlichiches Verhalten S7-315 / S7-1515 in kompination mit IO-Link Master AL1900

D_H

Member
Beiträge
15
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo zusammen,

Ich habe folgendes neues Problem:

Ich soll die beiden Schaltausgänge von einem PTC31B Druckschalter an einem AL2301 von IFM Auswerten.
Das ganze soll dan via IO-Link über den AL1900 Master via Profinet in die SPS (S7-315).

Der Druckschalter ist eingestellt und an de, AL2301 kommen die Signale auch an.

Der AL2301 überträgt 30Byte I/O.

Als eingangs-ausgangsadressen habe ich jeweileis 1000 angeben.

In meinem Versuchsaufbau letzte Woche habe ich die Komponenten an eine S7-1515f gehängt , selbe Hardwarekonfiguration, gleiche Tia Version(15.1), selbe Adressen.

Dort konnte ich dann auf E1002.0 und E1003.0 Pin 4 und Pin2 des AL2301 auslesen.

Das einzige was in der endgültigen Anlage anders ist, ist die CPU und hier kommen die Schaltsignale nicht an diesen adressen an.

Kennt jemand dieses vVerhalten und kann mir sagen, wo mein Fehler liegt?


Die Konfig des 2301 besagt, das Word 0 für Status bits ist und Word 2 die Binären Eingänge wiederspiegelt.
 

DOD666

Well-known member
Beiträge
570
Punkte Reaktionen
103
Es kann sein das die Adresse nicht mehr im verfügbaren adressenreich der CPU liegt. Schau mal in der Hardware Konfiguration nach.

Gruß Jens
 
OP
D

D_H

Member
Beiträge
15
Punkte Reaktionen
0
Zyklus.PNG

Ist es ein Nachteil, hier einen großen Wert einzustellen?

Interressant, habe selber nie eine 300er gemacht.
 

DOD666

Well-known member
Beiträge
570
Punkte Reaktionen
103
Früher zu Beginn der 300er war Speicher knapp und die Prozessorgeschwindigkeit nicht sehr hoch. Da war ein großes Prozessabbild belastend. Da brauchst du dir keinen Kopf drum machen. Erweitere es wie du es brauchst.
 
Oben