Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Protool

  1. #1
    Registriert seit
    01.08.2005
    Beiträge
    75
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich schlage mich erst sein neustem mit Protool herum!
    Ich will für eine OP 270 Störmeldungen und Betriebsmeldungen Archivieren und zur anzeige bringen. Kann aber keine vernünftige Anleitung finden , wie ich so etwas realisieren kann.

    bin für jede Hilfe Dankbar !!!
    Zitieren Zitieren Protool  

  2. #2
    Registriert seit
    07.06.2005
    Beiträge
    36
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also das ist eigentlich ganz einfach.

    Du öffnest die "Betriebsmeldungen" und schreibst bspw. in
    Zeile 0001: "Das erste Bit aus MW0 ist aktiv"
    Zeile 0002: "Das erste und das Bit aus MW0 sind aktiv"

    Nun unter Bereichszeiger "neuen Bereichzeiger einfügen" als Typ gibst Du "Betriebsmeldungen" an. Als Adress-Bereich gibst Du passend zu meinem Beispiel das MW0 an.

    Nun wird dezimal zugewiesen. (dez-1)
    MW=0 -> Zeile 0 // existiert aber ja nicht
    MW=1 -> Zeile 1
    MW=2 -> Zeile 2
    MW=3 -> Zeile 3

    Hoffe es hilft Dir weiter!

  3. #3
    Franz ist offline Benutzer
    Themenstarter
    Registriert seit
    01.08.2005
    Beiträge
    75
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Na ja es hat mir nicht weiter gebracht!

    Ich habe einen Motor: E0.0 ist für Motor in Betrieb und E0.1 ist für Motor Störung.

    In der "Betriebsmeldung" von Protool habe ich in die Zeile 0001 " Motor Betriet" hineingeschrieben. Und den Bereichszeiger (Betriebsmeldungen) auf MW 1 eingestellt.

    Wie kann ich diese Meldung zur anzeige bringen wenn der E0.0 gleich true ist.

    Danke

  4. #4
    Registriert seit
    07.06.2005
    Beiträge
    36
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das ist relativ einfach.

    Musst halt Deine Meldungen auf das entsprechende Bit des Zeigers mittels S7 setzen.

    Betriebsmeldungen (Bereichszeiger MW0):
    U E0.0 //Bit gesetzt
    = M0.1 // dann setze Merker 0.1 Betriebsmeldung Zeile 1 wird angezeigt

    Störmeldungen (Bereichszeiger MW2):
    U E0.1 //Bit gesetzt
    = M2.1 // dann setze Merker 2.1 Störmeldungen Zeile 1 wird angezeigt

  5. #5
    Franz ist offline Benutzer
    Themenstarter
    Registriert seit
    01.08.2005
    Beiträge
    75
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So ich habe es so gemacht wie beschrieben! Kann ich das mit ProTool/Pro RT simulieren ? Weil es immer noch nichts geschieht!

  6. #6
    Registriert seit
    15.11.2005
    Beiträge
    89
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo !

    Bei ProTool ist darauf zu achten, das HIGH/LOW Byte zu tauschen sind,
    also um beim Beispiel von MW0 projektierten Bereichszeiger zu bleiben

    M0.0 = Meldung 9
    M0.1 = Meldung 10
    M0.2 = Meldung 11
    M0.3 = Meldung 12
    M0.4 = Meldung 13
    M0.5 = Meldung 14
    M0.6 = Meldung 15
    M0.7 = Meldung 16
    M1.0 = Meldung 1
    M1.1 = Meldung 2
    M1.2 = Meldung 3
    M1.3 = Meldung 4
    M1.4 = Meldung 5
    M1.5 = Meldung 6
    M1.6 = Meldung 7
    M1.8 = Meldung 8

    Grundsätzlich würde ich Bereichszeiger nich auf Merkern abbilden,
    lieber einen DB, denn hast Du mal ne SPS mit asynchronen Zugriff
    (z.B. 31 musst die die Meldebereiche zwischenpuffern und erst
    am Ende des OB1 im eigentlichen Bereichszeiger des HMI Gerät
    eintragen.

    Cu, nairolf
    _________________________________________
    Solls funktionieren, oder darfs auch Siemens sein?

  7. #7
    Franz ist offline Benutzer
    Themenstarter
    Registriert seit
    01.08.2005
    Beiträge
    75
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke es geht ich musste nur die HIGH/LOW Byte tauschen
    Da muss mal erst mal darauf kommen!

    Vielen Dank

  8. #8
    Registriert seit
    15.11.2005
    Beiträge
    89
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ach ja, hab ich vergessen:

    MW1 ist unklug...

    MW0, MW2 usw

    cu, nairolf
    _________________________________________
    Solls funktionieren, oder darfs auch Siemens sein?

  9. #9
    Unregistriert Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von nairolf
    Hallo !

    Bei ProTool ist darauf zu achten, das HIGH/LOW Byte zu tauschen sind,
    also um beim Beispiel von MW0 projektierten Bereichszeiger zu bleiben

    Da hat nairolf Recht das habe ich vergessen.
    DB's sind auch immer besser als MW.

    Aber es ging bei meiner Erklärung auch nur ums Prinzip!

Ähnliche Themen

  1. Protool V1.x
    Von bresner1 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 13.07.2016, 19:31
  2. Antworten: 9
    Letzter Beitrag: 18.11.2009, 16:04
  3. Unterschied ProTool und ProTool Pro RT
    Von Anwender im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 17.01.2007, 18:09
  4. Antworten: 7
    Letzter Beitrag: 25.08.2005, 08:30
  5. Antworten: 2
    Letzter Beitrag: 03.05.2005, 07:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •