Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Anschaltung von RS232 TTL Messung an RS485 Schnittstelle

  1. #1
    Registriert seit
    07.06.2007
    Beiträge
    93
    Danke
    7
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    hoffe dass ich hier nicht ganz falsch bin

    Eigentlich ist es eine recht einfache Aufgabenstellung. Ein Bekannter hat eine VIPA314C und für seinen Öltank eine kleine Ultraschall-Füllstandsmessung (LevelJET von ProJET). Dieses kleine Multitalent hat auch eine RS232 Schnittstelle mit TTL Pegel die wir dazu verwenden wollten, um die Daten in die Steuerung einzulesen. Die 12 Byte Daten werden im Sekundentakt mit 19200/8/N/1 gesendet.
    Erster Gedanke, mit einem fertigen Modul, das einen MAX485 besitzt von RS232 TTL auf RS485 und damit auf die Schnittstelle der VIPA, die als PtP parametriert war. Dazu über die Bucht eine Hand voll aus Fernost bezogen und die Tests gingen los. Die erste Hürde war die Hardwareverkabelung. Der Schnittstellenwandler hat auf der "TTL-Seite" die Anschlüsse DI/DE/RE/RO und auf der RS485-Seite A/B. Mit dem RS485 Anschluss sind wir auf A/B an der CPU. Vom LevelJET haben wir den GND auf DE und den TXD auf DI des Schnittstellenwandlers angeschlossen.
    Soweit so schlecht - es kommen keine Daten in der CPU an Die Schnittstelle ist mit dem vipaspezifischen SFC216 (SER_CFG) parametriert und mit dem SFC218 (SER_RCV) empfangsbereit.

    Mit einem Oszi kommt das Signal schön aus dem LevelJET, nach Anschluss des MAX485 sieht es schon etwas unschön aus und auf der RS485 Seite ist es ganz kreuz und quer, aber vielleicht messen wir da auch falsch. Wir haben schon mehrere Anschlussmöglichkeiten durchprobiert und auch die Wandler getauscht.

    Hat jemand Tips zur Fehlersuche oder Lösungsvorschläge?

    Viele Grüße
    Eric
    Zitieren Zitieren Anschaltung von RS232 TTL Messung an RS485 Schnittstelle  

  2. #2
    Registriert seit
    02.09.2008
    Ort
    Algund
    Beiträge
    221
    Danke
    16
    Erhielt 13 Danke für 12 Beiträge

    Standard

    Hallo
    gib mal Bausteindetails (IC) an
    Falls das sowas ist wird dies nicht funktionieren
    http://1.bp.blogspot.com/-XOBcLTy5VE...600/rs4851.png

    Vermutlich wirst du um einen Kommunikationsprozessor nicht herumkommen...

    Gruß
    Geändert von simon.s (04.12.2015 um 10:32 Uhr)

    ICH WOHNE DA WO IHR URLAUB MACHT

  3. #3
    Registriert seit
    07.06.2007
    Beiträge
    93
    Danke
    7
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo simon.s

    Danke für Deine Antwort. Es ist ein MAX485, wie von Dir beschrieben. Was ich nicht verstehe, wieso soll das nicht funktionieren . Der MAX485 wandelt doch das RS232 TTL Signal in ein RS485 Signal um, oder? Die Auswertung der Kommunikation erfolgt über die PtP Schnittstelle der CPU. Wo liegt unser Denkfehler?

    Viele Grüße
    Eric

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.311
    Danke
    932
    Erhielt 3.321 Danke für 2.683 Beiträge

    Standard

    Mal zur Klarstellung:
    - Deine Schnittstelle ist keine RS232 sondern eine serielle Schnittstelle mit TTL-Pegel.
    - RS485 ist ein Bus mit Senden und Empfangen auf den selben Leitungen. Da reicht eine simple Pegelanpassung normalerweise nicht, da gehört noch eine Zugangslogik und Sende-/Empfangs-Richtungslogik dazu. Und es gehören dazu Abschlußwiderstände und eine Biasschaltung für definierte Pegel auf dem Bus wenn kein Teilnehmer sendet. (RS485-Physik mit getrennten Sende- und Empfangsleitungen wie die serielle Schnittstelle wäre eine RS422).

    Du kannst Glück haben, wenn die VIPA niemals in Senden geht.
    - Du müßtest an Deinem MAX485 /RE und DE zusammen an VCC (+5V) legen, dann steht der Chip fest auf Senden.
    - Du müßtest mindestens an einem Kabelende die 3 Abschlußwiderstände einbauen - am besten nimm einen Profibus-Stecker auf der VIPA-Seite, da ist die Widerstandsschaltung schon mit drin.
    - eventuell ist es nötig, die zwei Busleitungen A und B zu vertauschen

    Übrigens braucht man die 485-Treiber-Chips nicht aus Asien importieren, die gibt es für ein paar Euro in jedem guten deutschen Elektronik-Internetshop.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    Registriert seit
    07.06.2007
    Beiträge
    93
    Danke
    7
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo Harald,

    Danke für die Aufklärung und die vielen Tipps!!
    Die VIPA wird nie in Senden gehen, einen Profibusstecker haben wir schon getestet, eben wegen des Busabschlusses. Aber /RE und DE war noch nicht auf 5V gelegt, wird noch getestet und berichtet Die Leitungslänge des RS485 Abschnitts sind ca. 10m brauche ich da auch beiden Seiten die 3 Abschlusswiederstände, oder soll über die 10m besser der TTL Pegel geführt werden und die RS485 Strecke nur ein paar cm?

    Eine Frage stellt sich noch mit dem TTL Pegel, kommt der GND auf DE und TXD auf DI? Widerspricht sich das nicht in Bezug auf das Brücken von /RE und DE auf 5V?

    Die Chips wurden deshalb aus Asien importiert, da sie schon auf fertigen kleinen Platinchen mit Anschlüssen waren

    Viele Grüße
    Eric

    Anbei noch ein Schaltplan des verwendeten Platinchens. Eigentlich müsste nur GND des TTL Pegels auf GND des Chips und TXD auf DI, oder?
    Angehängte Dateien Angehängte Dateien
    Geändert von steinche (04.12.2015 um 13:38 Uhr)

  6. #6
    Registriert seit
    23.10.2009
    Beiträge
    399
    Danke
    59
    Erhielt 114 Danke für 88 Beiträge

    Standard

    Zitat Zitat von steinche Beitrag anzeigen
    Eine Frage stellt sich noch mit dem TTL Pegel, kommt der GND auf DE und TXD auf DI? Widerspricht sich das nicht in Bezug auf das Brücken von /RE und DE auf 5V?
    Nein, der TTL-GND kommt auf GND vom Platinchen, und der TXD auf DI. Die anderen Eingänge sind durch die Widerstände schon richtig beschaltet.
    Gruß
    Erich
    Geändert von LargoD (04.12.2015 um 16:04 Uhr) Grund: Schreibfehler

  7. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.311
    Danke
    932
    Erhielt 3.321 Danke für 2.683 Beiträge

    Standard

    Die Platine kommt so nahe wie möglich an die TTL-Schnittstelle. Du mußt nur VCC (+5V), GND und DI (TXD) anschließen. Die RS485-Seite (A und B) kann 50m lang sein (Siemens-Empfehlung bei nicht potentialfreier RS485).
    Ich glaube, bei Deiner Platine sind die Widerstände R5 und R6 falsch geschaltet - A wird nach VCC(+) gezogen und B nach GND(-). Bei Siemens/VIPA wird B nach (+) gezogen und A nach (-).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #8
    Registriert seit
    24.03.2010
    Beiträge
    126
    Danke
    3
    Erhielt 26 Danke für 21 Beiträge

    Standard

    Hallo,

    die Widerstände sind schon genau richtig so.
    Man muss dazu berücksichtigen, dass die Baustein (Chip) Anschlüsse A+B !!!NICHT!!! den
    allgemein üblichen RS485 Anschlussbezeichungen entspricht.
    Bei dauernd eingeschaltetem Sender ist die Widerstandskombination aber eh überflüssig.

    TTL GND kommt auf GND, TTL TxD kommt auf DI;
    -RE kommt auf +5V, DE kommt auf +5V; Machen die Widerstände auf der Platine schon.
    Platine gehört nah an TTL-Schnittstelle (<1m); RS485 kann bis zu 1000m oder mehr.

    Dann muss man noch berücksichtigen, dass MAX485 A auf Siemens/Vipa B gehört und
    MAX485 B auf Siemens/Vipa A. Dann klappt das auch.

    mfg
    Erdmann

  9. #9
    Registriert seit
    26.10.2014
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Harald Hallo Erdmann,

    mein Name ist Jürgen und ich habe das Problem mit der Schnitstelle, Eric hat mich Tatkräftig unterstüzt.

    Ich habe eure Vorschläge durch gearbeitet leider ohne Erfolg, im Moment glaube ich, dass die Schnitstellen einen Schlag weg haben (2 werden Heiß 2 bringen nur wirres Zeug).
    Ich werd mir eine neue Schnitstelle zulegen, habt ihr einen Tip für mich mit welchem Modul es funktionieren könnte.

    Gruß
    Jürgen

  10. #10
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.311
    Danke
    932
    Erhielt 3.321 Danke für 2.683 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jürgen,

    Deine MAX485-Module müssten grundsätzlich geeignet sein.

    Du kannst die Module gegenseitig testen, ob sie noch funktionieren. Dazu ein Modul als Sender mit einem Modul als Empfänger verbinden.

    Sendemodul:
    - VCC: +5V anschließen
    - GND: GND anschließen
    - DI, RO, DE und RE nichts anschließen
    - A und B mit A und B des Empfänger-Moduls verbinden

    Empfänger-Modul:
    - VCC: +5V anschließen
    - GND: GND anschließen
    - DE und RE mit GND verbinden
    - DI nichts anschließen
    - an RO Spannungsmesser gegen GND oder Leuchtdiode mit Vorwiderstand mind. 470 Ohm bis 1 kOhm gegen VCC anschließen
    - A und B sind mit A und B des Sender-Moduls verbunden

    Testen:
    - Sender.DI nichts angeschlossen --> Empfänger.RO sollte ca. 4,5V haben, LED dunkel
    - Sender.DI mit GND verbinden --> Empfänger.RO sollte ca. 0,2V haben, LED leuchtet
    - Sender.DI den TxD von Deinem LevelJET anschließen und Ground mit GND verbinden --> Empfänger.RO die LED sollte im Sekundentakt kurz aufblitzen/flackern (die LED leuchtet bei L-Bits)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

Ähnliche Themen

  1. RS232 - RS485 Konverter
    Von piffpaff im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 19.05.2009, 20:40
  2. RS232 zu RS485 PC-Adapter von Siemens
    Von Peterle im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 06.11.2007, 13:04
  3. RS232 / RS485 Adapter
    Von digga im Forum HMI
    Antworten: 0
    Letzter Beitrag: 28.06.2007, 14:39
  4. Rs485-rs232
    Von carstenroll im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 26.03.2007, 20:13
  5. Antworten: 4
    Letzter Beitrag: 13.07.2006, 08:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •