Absolutwertgeber mit SSI-Interface

PeterEF

Well-known member
Beiträge
985
Punkte Reaktionen
108
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,

kennt sich jemand mit sowas aus? Für eine zu überarbeitende Steuerung kriege ich Positionen als Absolutwert aus einem Geber mit SSI-Interface, meine Schnittstelle dabei ist je ein INT32 mit dem Wert, die Meßhardware besteht aus einem Jäger-Meßsystem.
Bei er Inbetriebnahme des Reglers nun stellt sich heraus, das es starke Störungen beim Meßwert gibt, sowohl Spitzen nach oben als auch nach unten. Wir sind uns sicher - der Regler ist es nicht, er reagiert aber auf die Störung, darum kann die geforderte Genauigkeit (XY-Positionierung) nicht eingehalten werden.

Wo könnte man die Leute vor vor Ort nach der Störung suchen lassen (angeblich ist alles in Ordnung...)

Peter
 

SPS Markus

Well-known member
Beiträge
324
Punkte Reaktionen
10
Hallo Peter,

hatte auch schon mal Probleme in dieser Richtung. Bin mir aber nicht mehr sicher ob es ein SSI-Geber war. Das Problem lag an der Verdrahtung, bzw. genauer gesagt an der Schirmung. Der Schirm war durch einen unvorsichtigen Mechaniker angebohrt worden. Kabel ausgewechselt und alles war OK!
Wenn das Protokoll was der Geber sendet nicht mehr richtig ankommt, könnte die Auswertung das falsch interpretieren.

Nur mal so als Tip

Markus
 

Oberchefe

Well-known member
Beiträge
2.096
Punkte Reaktionen
292
Zuviel Werbung?
->Hier kostenlos registrieren
Ich habe auch schon defekte Geber gesehen, die Istwertsprünge machten aber beim Selbstcheck nichts ungewöhnliches feststellen konnten. Um dies zu erkennen, sollte man eine Plausibilitätsprüfung einfügen (wie stark kann sich der Istwert vom einen Einlesen zum nächsten maximal ändern). Bei einer Neuinstallation kommt aber natürlich auch die Verkabelung in Frage (Siehe oben).
Die Taktfrequenz paßt aber schon zur Kabellänge (oder anders herum gesagt:taktest Du für Deine Kabellänge langsam genug)?

EMV-Probleme (Magnetventile, Schütze.....) sind auch noch in Betracht zu ziehen.
 
OP
P

PeterEF

Well-known member
Beiträge
985
Punkte Reaktionen
108
Danke für die Antworten. Kann es sein, das folgendes unzulässig ist: das Gebersignal (SSI) wird parallel an ein Sicherheitsrelais (Pilz Pnozmulti) und an die eigentliche Steuerung geführt - sowas hab ich noch nicht gesehen (man will wohl den Aufwand für einen zweiten Satz Geber sparen). Bis jetzt hat mich das nicht bekümmert, wir liefern hierbei nur Software......

An der Leitungslänge kann es nicht liegen, die gleiche Leitung am Geber funktionierte mit der alten Steuerung 10 Jahre lang.

Schönen Abend noch, Peter
 

Zottel

Well-known member
Beiträge
2.299
Punkte Reaktionen
277
Was macht das Sicherheitsrelais denn mit einem SSI Signal? Habe noch nie von einem Sicherheitsrelais mit Drehgeberauswertung gehört, aber ich lerne gerne dazu.
Sollte das Sicherheitsrelais KEINE SSI-Schnittstelle haben, ist die Verdrahtung falsch.
Sollte es doch eine haben, ist es trotzdem zweifelhaft, ob der Geber 2 Empfänger beliefern kann.
Weiss leider zu wenig über SSI.
Wenn es Sende- und Emfangsleitungen hat, dürfen mit Sicherheit die Leitungen, die zum Geber senden, nicht auf zwei Partner geführt werden.
Aber ich würde immer probieren, den Geber nur auf die Steuerung zu führen, Eventuell ist es ja möglch für einen Versuch das Sicherheitsrelais zu "brücken".
 

Kurt

Well-known member
Beiträge
462
Punkte Reaktionen
16
Zuviel Werbung?
->Hier kostenlos registrieren
Da ght es mir wie Zottel.

Was tut das SSI Signal beim PNOZmulti und wenn es ein PNOZmulti mit SSI Eingang gibt, dann geht das Ganze auch in die Hose.

Einfache Darstellung:
Der SSI-Empfänger (Steuerung) sendet über TAKT einen Takt.
Entsprechend dem Taktsignal sendet (schiebt) der Geber seinen Positionswert (Bit)seriell über die DATA Leitung in den Empfänger.

Da der Geber nur dann auf DATA was ausgibt wenn die Steuerung mit Takt was anfordert (Triggert) und der Geber seinen Positionszählerstand seriell über DATA sendet, heißt es eben SynchronSeriell -> SSI.

Variante 1:
Wenn ich nun zwei Steuerungen und einen Geber habe, dann sendet jede Steuerung einen Takt - wobei sich der Pegel der Steuerung mit der robusteren Ausgangstreibern durchsetzt, der Geber ist ganz verwirrt und sendet seine Daten, bricht ab und ....
Zufall wenn da mal was richtig ankommt.

Variante 2:
Zwei Steuerungen aber man verwendet nur von einer Steuerung den TAKT. Die zweite Steuerung soll nur horchen was der Geber so sendet.
Die Steuerung die den Takt macht, wird nun korrekt funktionieren, sofern die zweite Steuerung den Pegel auf DATA nicht elektrisch vermurkst (nicht sehr wahrscheinlich).
Die zweite Steuerung, die ja das Auslesen ihres Empfangspuffers (FIFO) nach dem von ihr erzeugten Takt triggert, hat ein Problem, da sich zum Zeitpunkt des Auslesens immer nur Fragmente des Geberwertes (Telegrammes) im Puffer befinden. Der Geber sendet ja zum Takt von Steuerung1.

ALSO:
Wenn zwei Systeme einen Geberwert benötigen, dann geht das mit SSI nicht, weil man den Takt der beiden Systeme (Steueurngen) nicht synchronisieren kann!

Kurt
 

Markus

Administrator
Teammitglied
Beiträge
5.272
Punkte Reaktionen
1.305
Kurt schrieb:
Die zweite Steuerung, die ja das Auslesen ihres Empfangspuffers (FIFO) nach dem von ihr erzeugten Takt triggert, hat ein Problem, da sich zum Zeitpunkt des Auslesens immer nur Fragmente des Geberwertes (Telegrammes) im Puffer befinden. Der Geber sendet ja zum Takt von Steuerung1.

ALSO:
Wenn zwei Systeme einen Geberwert benötigen, dann geht das mit SSI nicht, weil man den Takt der beiden Systeme (Steueurngen) nicht synchronisieren kann!

Kurt

erstmal vielen dank für die tolle beschreibung!

aber wenn ich zwei steuerungen habe, dann definiere ich eine als master und eine als slave.

der master macht den takt und gibt diesen an den geber und auf einen eingang vom slave. der slave triggert sein fifo mit diesem eingang - also dem takt von steuerung 2. auf der datenleitung horchen wie beschrieben beide...

wären die beiden steuerungen dann nicht synchron?
 

ralfm

Well-known member
Beiträge
175
Punkte Reaktionen
0
Hallo,

ich kenne diese gelben (Stegmann?) Geber, da gab es öfters Probleme beim anlöten des Steckers. Teilweise hat sich ein drähtchen der Abschirmung durch eine Signalleitung gebohrt.

Grüße
Ralf
 

Kurt

Well-known member
Beiträge
462
Punkte Reaktionen
16
Zuviel Werbung?
->Hier kostenlos registrieren
wären die beiden steuerungen dann nicht synchron?

Es handelt sich beim Takt nicht um eine feste 'endlose' Frequenz sondern um ein Frequenzpaket, dann eine Pause und ein Paket und eine Pause....

Der Takt taktet die Positionsdaten aus dem Geber in den FIFO des Auswärtegerätes. Mit der Pause, weis der Geber, JETZT ist Schluss, das Auswärtegerät kopiert den FIFO-Inhalt weg und holt die Position raus und löscht den FIFO.
Beim nächsten Taktbeginn (ImpulsPaketanfang) muss der Geber wieder neu mit den Positionsdaten (von Vorne MSB) zu senden beginnen, damit im FIFO des Auswärtegerätes jedes Bit aus dem Geber auf der richtigen BitStelle im FIFO steht.

Das Auswertegerät (Steuerung) triggert sich selber mit seinem eigenen Takt (Impulspaket und Pause) triggert-> (FIFO wegkopieren und löschen).

Die zweite Steuerung die nur mithorcht, bekommt immer nur Stücke der Daten die von der ersten Steuerung aus dem Geber geschoben werden, und diese Stücke sind im FIFO noch dazu an der falschen (Bit)Stelle.
Es müsste also die Pause der zweiten Steuerung synchronisiert werden, damit das mithorchen funktioniert.

Kurt
 
A

Anonymous

Guest
Dankeschön....

.. an alle Antworter, das hat uns weiter geholfen. Jetzt weiß ich endlich, wie SSI funktioniert. Der Fehler scheint in einem Steckverbinder zu liegen, soweit man das aus der Ferne beurteilen kann und wird wohl gerade beseitigt.
Die Sicherheitsmodule (PILZ) haben in der Tat kein SSI-Interface - das war eine Fehlinformation, sondern einen Eingang für Inkrementalgeber, ob man diese parallel schalten darf (ein Geber für zwei Senken) ist ein anderes Thema.

Schönen Tag noch, Peter
 
Oben