Automatische Programmänderung S5

Balou

Well-known member
Beiträge
221
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Moin

wir haben bei uns mehrere Anlagen mit S5 laufen.
Als wir letzte woche nach einem Osterstillstand eine Anlage wieder einschalten wollten lief diese nicht einwandfrei (obwohl kein Elektriker dran war)
Nach einer Fehlersuche mit dem PG stellten wir fest das ein Eingang der Im Normalen Programm nicht negiert ist Plötzlich negiert war.
Auch in der Aktuellen Doku war er nicht negiert nach dem neu Laden des Progis (Baustein) gings dann einwandfrei.

Ein Kollege sagte mir das daß schon mal Passiert war ist aber schon ein bischen her.

Hat jemand ne Ahnung oder Erfahrung wie sowas Passieren kann?

Mit freundlichen Grüßen

Balou
 

Onkel Dagobert

Well-known member
Beiträge
4.981
Punkte Reaktionen
953
Hardwarefehler?

Moin Balou,

daß sich das Programm selbstständig verändert hat, ist ziemlich unwahrscheinlich. Könnte es sein, daß der Eingang von der Hardware nicht richtig erkannt wurde? Ich kenne solche Ausfälle an einer ganz bestimmten Anlage, die wir betreuen. Durch agressive Umgebungsbedingungen die sich auch durch Gegenmaßnahmen nicht völlig beseitigen lassen, fallen regelmäßig Eingangsbaugruppen aus. In meinen Fällen ist dann ein Eingang ständig "high" oder "low". Manchmal funktioniert es zwischenzeitlich noch einmal. Es ist aber nicht so, daß der Eingang definitiv als negiert erkannt wird. Falls dein beschriebener Fehler noch einmal auftritt, würde ich die Baugruppe austauschen.

Gruß, Onkel
 
OP
B

Balou

Well-known member
Beiträge
221
Punkte Reaktionen
0
Zuviel Werbung?
->Hier kostenlos registrieren
Ausfall

Moin

Die Baugruppe ist eigentlich keinen Besonderen bedingungen FU's hitze oder so ausgesetzt.

Anhand der letzten Doku konnte ich erkennen das der E nicht negiert war und im Online Modus war der E Plötzlich negiert und es kann sich niemand erklären warum es da Online offline unterschiede gibt.

Nach einem neuladen des Baustein lief wieder alles.

MfG
Balou
 

EWS

Well-known member
Beiträge
50
Punkte Reaktionen
0
Hi

das ist ganz einfach. Wenn Du eine Batterie und ein EProm in Deiner S5 hast.
Die Batterie puffert den Arbeitsspeicher und wenn die Anlage etwas länger
ausgeschaltet ist und die Batterie etwas schwach auf der Brust holt die CPU sich das Programm von EProm.
Das heit die letzten Änderungen hab Ihr nicht auf dem EProm gespeichert sondern nur Online im Arbeitsspeicher.
Ansonsten ändert sich ein Programm nicht.

netten Gruß

Christian Werner

PS: Bei S7 mit Batterie und Memory Card geht sowas auch.
 
OP
B

Balou

Well-known member
Beiträge
221
Punkte Reaktionen
0
S5

Moin

habe heute die Anlage noch einmal Kontroliert

es ist kein EPROM in der CPU die Pufferbatterie ist im AUG 03 gewechselt.

Ich habe mich im Übrigen vertippt es ist ein Merker

und das Progi ist seit eh und je ohne Negation.

Bei uns kann sich niemand erklären warum das Pssiert ist das Magnetventil welches damit angesteuert wird kann auch nur so Arbeiten.

Also bei uns herscht RATLOSIGKEIT!

MfG
Balou
 
A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Änderung

na is schon sehr naiv die Frage. Ich denke es hat jemand dranrumgespielt. Oder denkste es dreht sich einfach ne Abfrage? Auch nich bei nem Speicherfehler. Eher geht dann gar nichts mehr.

Schönen Abend
Frank
 
Oben