WinCC Unified Lokale Benutzerverwaltung zur Laufzeit verwalten

Tschoke

Level-2
Beiträge
292
Reaktionspunkte
153
Zuviel Werbung?
-> Hier kostenlos registrieren
Weiß jemand ob und wie man bei Unified Benutzer zur Laufzeit ändern/löschen/anlegen kann?
Es gibt bei Unified kein Control wie z.b. bei Advanced dafür.
Ich habe es über das Browser Control über https://computername/umc versucht.
Das funktioniert aber nicht.
Kann man wirklich Benutzer nur mit TIA verwalten?
 
Es gibt bei Unified kein Control mehr, es läuft über UMC, wie du schon gefunden hast. Entweder per anderem Tab oder im Browser-Control in der Runtime.
vgl. die Doku

Dort kann man auch zur Runtime Benutzer hinzufügen, ändern und löschen.

Was heißt "Das funktioniert aber nicht"? Es kommt eine Fehlermeldung? Du kommst nicht in UMC rein?
Welche TIA-Version? Welche Unified-Runtime-Version?
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Ok. Dann bin ich erstmal froh das überhaupt geht.
Was heißt "Das funktioniert aber nicht"?
Wenn ich in der Runtime über Browser Control https://computername/umc aufrufe kommt das:
1711117326370.png

Ich habe einen Benutzer unter "Security-Einstellungen" angelegt und ihm (testweise) alle Rollen zugewiesen.

Welche TIA-Version? Welche Unified-Runtime-Version?
TIA 19
WinCC Unified 19



Noch eine Verständnisfrage:
Die lokale Benutzerverwaltung heißt doch UMAC, oder?
Und die zentrale heißt UMC, oder?
Warum rufe ich über die Adresse https://computername/umc die lokale Benutzerverwaltung auf?
 
Anhang anzeigen 76631

Ich habe einen Benutzer unter "Security-Einstellungen" angelegt und ihm (testweise) alle Rollen zugewiesen.
Die Rollen bringen im ersten Schritt nicht direkt etwas.
Der Benutzer benötigt das Funktionsrecht "Benutzerverwaltung"/"User Administration". Die HMI-Administrator-Rolle hat das entsprechende Recht, was man auch im TIA-Portal sieht.
1711368174710.png
1711368208588.png

Hast du die Benutzerdaten auch in die Runtime reingeladen? Das muss man im Ladedialog ja explizit anhaken, da fällt man gerne man drauf rein
1711368457434.png
TIA 19
WinCC Unified 19
Es schadet vielleicht nicht, gleich Update 1 zu installieren.
Noch eine Verständnisfrage:
Die lokale Benutzerverwaltung heißt doch UMAC, oder?
Und die zentrale heißt UMC, oder?
Warum rufe ich über die Adresse https://computername/umc die lokale Benutzerverwaltung auf?
Die Benutzerverwaltung im TIA-Portal heißt UMAC. Also alles im Punkt "Benutzer und Rollen" im TIA-Portal mit allen Folgen, die man damit einstellt. Sprich die Benutzerverwaltung von WinCC Unified, der Projektschutz des TIA-Portals, die PLC-Benutzerverwaltung, die mit FW3.1 in V19 auch dort reingewandert ist.
UMC ist im ersten Schritt die zentrale Benutzerverwaltung, an die sich das TIA-Portal und WinCC Unified ankoppeln und nutzen können.
Bspw. ist in der Firma ein UMC-Server, der im Hintergrund mit der Domäne verbunden ist. Dann lassen sich im UMC-Server Firmenbenutzer verwenden und es kann bspw. eingestellt werden, dass bestimmte Mitarbeitergruppen bestimmte Rechte haben. Bspw. bestimmte Bilder in Unified bedienen oder im TIA-Portal nur HMI-Änderungen durchführen, aber keine PLC-Änderungen.
Im Endeffekt kann man sich dann in Unified oder dem TIA-Portal mit seinen Firmen-Credentials anmelden und hat darauf aufbauend bestimmte Rollen und Rechte

Warum jetzt in Unified auch die lokale Benutzerverwaltung UMC heißt? Gute Frage, wahrscheinlich wird im Hintergrund derselbe Mechanismus genutzt, nur eben rein lokal. Aber das ist nur vermutet, vielleicht ist es auch einfach nicht ganz saubere Namensgebung von Seiten Siemens.
 
Ich habe keine Ahnung was jetzt anders ist oder was ich geändert habe????
Auf jeden Fall kann ich mich jetzt anmelden.

Aber wenn ich in der Weboberfläche einen Benutzer hinzugefügt habe, kann ich diesem keine Rolle zuweisen.
Da kommt das:
1711383637363.png
Und die Rolle (egal welche gewählt wurde) wird nicht übernommen.

Wenn ich in den Gruppen (egal welche) versuche einen Benutzer zuzuweisen, kommt das:
1711383814945.png
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Ich habe keine Ahnung was jetzt anders ist oder was ich geändert habe????
Auf jeden Fall kann ich mich jetzt anmelden.

Aber wenn ich in der Weboberfläche einen Benutzer hinzugefügt habe, kann ich diesem keine Rolle zuweisen.
Da kommt das:
Anhang anzeigen 76657
Und die Rolle (egal welche gewählt wurde) wird nicht übernommen.

Wenn ich in den Gruppen (egal welche) versuche einen Benutzer zuzuweisen, kommt das:
Anhang anzeigen 76658
Das klingt jetzt nach einem Fall für den Siemens Support...
 
Also, ich habe Unified und TIA geupdatet.
Danach kam ich wieder nicht in die Benutzerverwaltung rein wegen: "Sorry, you have no access to user-management"...
Dann habe ich Siemens gefragt.

Zu dem Problem, "Sorry, you have no access to user-management":
Browser Cache löschen

Zu dem Problem, kann keine Rollen einem Benutzer zuweisen:
Wurde mit Update 1 behoben.
 
Zurück
Oben