s7 315 2db online

A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
guten tag allerseits

ich hätte ein kleines problem mit meiner steuerung

hab gerade einen FB beobachtet dabei ist die s5.2 abgestürzt

ab diesen zeitpunkt bekomme ich zu einigen (!!!) fb keine verbindung mehr

Fehlermeldung - Triggerfehler db36

ich gehe über die ethernetschnittstelle online

pg aus ein schon getestet

mfg

peter
 

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
302
Das habe ich noch nie gehabt.

- Ist die S7 noch im Run?
- Kannst du auf "erreichbare Teilnehmer" klicken und die SPS sehen?
- Versuch mal einen AG-PG Vergleich
- Wenn du im Simatic Manager Online kommst, kannst du dort die Bausteine online öffnen?

pt
 

Maxl

Well-known member
Beiträge
1.385
Punkte Reaktionen
181
Zuviel Werbung?
->Hier kostenlos registrieren
"Fehler .... Das Triggerereignis ist belegt"

Bei einer S7-300 CPU kann generell nur 1 FC/FB auf einmal beobachtet werden (nur 1 Triggerereignis vorhanden). Stürzt jetzt während dem Beobachten der Bausteineditor ab, wird der Status nicht korrekt geschlossen und der Trigger bleibt somit belegt!
Die einzige Abhilfe ist hier normalerweise Spannungsversorgung aus - und wieder ein. Ob der Trigger nach einer maximalzeit wieder freigegeben wird, ist mir nicht bekannt!
 

Onkel Dagobert

Well-known member
Beiträge
5.281
Punkte Reaktionen
1.086
Hallo,

was passiert eigentlich, wenn mehrere Teilnehmer mit Step7 über Ethernet auf eine S7 zugreifen? Ist das überhaupt möglich? Ich weiss es nicht.

Gruss, Onkel
 

Zefix

Well-known member
Beiträge
484
Punkte Reaktionen
74
Onkel Dagobert schrieb:
Hallo,

was passiert eigentlich, wenn mehrere Teilnehmer mit Step7 über Ethernet auf eine S7 zugreifen? Ist das überhaupt möglich? Ich weiss es nicht.

Gruss, Onkel

Hab grad kein Step zur Hand, aber ich glaube unter den CPU Eigenschaften gibts doch eine Rubrik mit den Verbindungseigenschaften.
Also wieviel OP´s etc. für Verbindungen... und für PG oder so.

Gruss Zefix
 

KaffeeSaufenderKamin

Well-known member
Beiträge
143
Punkte Reaktionen
3
Zuviel Werbung?
->Hier kostenlos registrieren
@Onkel

mit mehreren PG´s über Ethernet geht problemlos.
Bei der 300´er sind die Triggerereignisse aber schnell erschöpft ( 2 Bausteine Online / 1 Variablentabelle ).
Bei der 400´er muss man sich schon mühe geben, bevor sie keinen weiteren Trigger mehr zulässt.

@Gast & Maxl

Ist mir auch schon passiert. Das Triggereigniss wird nicht von der CPU aufgehoben, auch nicht nach Zeit X. Da hilft wirklich nur Spannung AUS / EIN. Selbst ein Start / Stop hilft nicht.

Falls das in der Anlage nicht so ohne weiteres möglich ist kann man sich so behelfen :

Baustein unter anderer Nummer abspeichern.
Laden
Aufruf des Bausteins anpassen.
Mit dem neuen Baustein weitermachen.
 

Jochen Kühner

Well-known member
Beiträge
4.186
Punkte Reaktionen
479
infos zum triggerfehler...

erstmal:
ich finde den topic nicht sehr informativ...

zweitens:
ich hatte das problem mit dem triggerereigniss auch über teleservice. habe nen baustein gändert, konnte ihn dann aber nicht mehr hochladen! habe dann die cpu online geöffnet, den baustein online geöfnnet, beobachtet, geschlosse und siehe da, ich konnte meinen übertragen!
 

plc_tippser

Well-known member
Beiträge
2.500
Punkte Reaktionen
302
Zuviel Werbung?
->Hier kostenlos registrieren
Re: infos zum triggerfehler...

Jochen Kühner schrieb:
erstmal:
ich finde den topic nicht sehr informativ...

zweitens:
ich hatte das problem mit dem triggerereigniss auch über teleservice. habe nen baustein gändert, konnte ihn dann aber nicht mehr hochladen! habe dann die cpu online geöffnet, den baustein online geöfnnet, beobachtet, geschlosse und siehe da, ich konnte meinen übertragen!

Wieso? Die Verbindung klaptt wieder, es gibt das Problem öfter, es gibt diese und jene Möglichkeit das es wieder läuft. Du selber hast doch zum Informationsinhalt beigetragen!

Ich finde den ganz gut und werde mich sicher/hoffentlich daran erinnern, wenn das Problem bei mir auftritt.

pt
 
Oben