TIA TIA V14 komplett und richtig deinstallieren

SPSnewbie91

Level-2
Beiträge
174
Reaktionspunkte
10
Zuviel Werbung?
-> Hier kostenlos registrieren
Hallo zusammen.

Ich möchte auf einer VM (Windows 10) das TIA Portal V14 komplett deinstallieren.
Installierte Software ist: TIA Portal V14 SP1 Update 10, TIA Portal Openness V14 SP1 Update 6, SINAMICS Startdrive V14 SP1 Update 8, STEP7 Professional V14 SP1 Update 10, STEP7 Safety V14 SP1 Update 8, WinCC Professional V14 SP1 Update 10
VM: VM Workstation 17

Es geht darum, dass wir momentan verschiedene VMs erstellen mit den jeweiligen TIA Versionen. Aktuell haben wir nur V14 und V17. Ich habe mir einen Klon der VM V14 erstellt und würde dort gerne V13 installieren, da wir noch ein paar alte Projekte in dieser Version haben. Ich habe mal gehört, dass es zu Problemen führen kann, wenn mehrere TIA Versionen installiert sind bzw. noch irgendwelche Restdateien vorhanden sind. Deshalb möchte ich V14 wirklich restlos von der VM entfernen und anschließend V13 installieren.
Gibt es da irgendwas auf das ich achten muss oder reicht es einfach über die jeweiligen Installationsassistenten die Software zu deinstallieren?
 
WTF?
warum nicht einfach eine saubere VM mit nur Windows nehmen und dort V13 installieren?

Das ist doch der Vorteil von VM das man das ganze Deinstall gedöns gar nicht machen muss?
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Das ist eine gute Frage :D.
Folgendes Problem. Wir haben eine blanke Windows 10 Version als VM. Dort hätte ich auch versucht V13 zu installieren. Hat auch geklappt. Nur habe ich auf dieser VM das Problem, dass ich keine Verbindung mit dem Siemens Server aufbauen kann um bspw. Updates runterzuladen. Außerdem wird in dieser VM mein USB Stick nicht erkannt. Ich habe keine Ahnung warum das nicht funktioniert. Die VM mit der blanken Windows 10 Version und die VM mit TIA V14 sind von den Einstellungen her völlig identisch. In der VM mit V14 wird mein USB Stick erkannt und ich kann auch Updates runterladen. Deshalb schien es mir einfacher einen Klon zu erstellen, da ich wirklich nicht weiß warum ich bei der blanken VM keine Verbindung zu den genannten Dingen herstellen kann.
 
vermutlich weil die V13 Updater eine veralterte TLS Version verwendet die vom Server nicht mehr unterstützt wird.
Also entwedere neueren SW Updater installieren oder die Updates direkt aus dem SIOS laden und manuell installieren

wird der USB in der reinen Win10 VM erkannt ?(taucht unter shared devices auf)
 
Nein wird er nicht. Nur in der VM auf der TIA V14 installiert ist wird er erkannt.

Hier mal ein Vergleich.

VM TIA V14:
1690274555927.png
1690274597608.png
1690274783493.png



VM Windows 10 blank:

1690275223131.png
1690275285585.png
1690275306242.png
 

Anhänge

  • 1690274621367.png
    1690274621367.png
    93,6 KB · Aufrufe: 3
Zuviel Werbung?
-> Hier kostenlos registrieren
ähm die beiden VM laufen aber nicht gleichzeitig?
Weil wenn doch kann der USB schon an der TIA V14 hängen dann gibt es probleme den an der anderen VM zu sehen

Deswegen sollte man die option "Remember my choice and dont ask again" auch nicht aktivieren
den die option macht nichts anderes als beim Einstecken des USB Devices dieses gleich an die VM weiterzugeben ohne das der horst das mitbekommt.

bei mir werden alle USB Geräte immer erst an den Horst connected und dann per "Removable Devices" and die VM assigned wo ich das brauche
 
Ich habe auch schon versucht den USB Stick über Shared Folders freizugeben. Nur kann der TIA Licence Manager nicht auf die Shared Folders zugreifen. Ich muss also direkt auf den USB Stick Zugriff bekommen, weil dort meine Lizenzen drauf sind.
 
ähm die beiden VM laufen aber nicht gleichzeitig?
Weil wenn doch kann der USB schon an der TIA V14 hängen dann gibt es probleme den an der anderen VM zu sehen

Deswegen sollte man die option "Remember my choice and dont ask again" auch nicht aktivieren
den die option macht nichts anderes als beim Einstecken des USB Devices dieses gleich an die VM weiterzugeben ohne das der horst das mitbekommt.

bei mir werden alle USB Geräte immer erst an den Horst connected und dann per "Removable Devices" and die VM assigned wo ich das brauche
Nein. Laufen nicht gleichzeitig. Sieht man an den grünen Play-Symbolen
 
Zuviel Werbung?
-> Hier kostenlos registrieren
also für Lizenzen verwende ich host Only Networks
jede VM hat einen Host Only Interface
auf dem Horst ist ALM und alle Lizenzen und die für Remote belegen freigegeben
in der VM dann Host-only aktivieren, ALM Starten und per IP mit dem Horst ALM Server verbinden und ihen als Favorit und suchliste aufnehmen dann belegt die VM die Lic auf dem Horst "remote" und ich muss da nix per USB transferieren.
 
Funktioniert das dann auch, wenn ich die VM meinen Kollegen zur Verfügung stelle? Weil Host-Only klingt für mich so, dass ich die Lizenzen auf meinem Rechner habe und das TIA in der VM die Lizenz direkt vom Host, also meinem Rechner, zieht. Das würde ja dann nur bei mir funktionieren oder hab ich grad einen Denkfehler?
 
keinen Denkfehler, die Lizenz ist auf deinem Rechner.
Weitergabe von VM an Kollegen -> Lizenzbedingungen verletzt
nun ich halte nichts davon Lizenzen weiterzugeben, das ist in der Regel illegal und nicht erlaubt
 
Zuviel Werbung?
-> Hier kostenlos registrieren
Ist natürlich eine Auslegung der Sprache. "Weitergeben" ist schon erlaubt, aber sie darf natürlich nur ein Mal vorhanden sein.
Zum USB Problem. Funktionierende VM starten, usb darin abmelden, VM beenden. Jetzt sollte der USB Stick im Host zu sehen sein. Dann die andere VM starten und den Stick übernehmen.
 
Ist natürlich eine Auslegung der Sprache. "Weitergeben" ist schon erlaubt, aber sie darf natürlich nur ein Mal vorhanden sein.
Zum USB Problem. Funktionierende VM starten, usb darin abmelden, VM beenden. Jetzt sollte der USB Stick im Host zu sehen sein. Dann die andere VM starten und den Stick übernehmen.
Habe ich schon versucht. Hat nicht funktioniert. Unter Removable Devices ist "Connect" ausgegraut.
 
also für V13 auf jeden Fall ne neue VM mit Win7 bauen...

Nur V13SP2 wäre für Win10 kompatibel und auch nur für ältere...

Deinstallationen sind immer problematisch...

Nur habe ich auf dieser VM das Problem, dass ich keine Verbindung mit dem Siemens Server aufbauen kann um bspw. Updates runterzuladen.

für V13 gibts keine Updates mehr...
 
Zuviel Werbung?
-> Hier kostenlos registrieren
also für V13 auf jeden Fall ne neue VM mit Win7 bauen...

Nur V13SP2 wäre für Win10 kompatibel und auch nur für ältere...

Deinstallationen sind immer problematisch...



für V13 gibts keine Updates mehr...
Ok. Für Windows 7 finde ich leider keine .iso mehr. Windows 8.1 habe ich noch als Download bei Microsoft gefunden. Sollte auch kompatibel sein oder?
 
Zuviel Werbung?
-> Hier kostenlos registrieren

mal so auf die schnelle...

Aber Lizenzkey und Aktivierung ist dann halt das nächste Thema...
Danke. V13 SP2 kann ich dann aber nicht installieren oder?
 
Zurück
Oben