TIA G120X mit Sina_Speed ansteuern

Vex

Level-1
Beiträge
19
Reaktionspunkte
0
Zuviel Werbung?
-> Hier kostenlos registrieren
Hallo liebe Communitiy,

ich stehe zur Zeit vor einem Problem und zwar sieht die Ausgangssituation wie folgt aus.

Ich muss einen Siemens G120X mit Hilfe einer S7-314C-2DP ansteuern. Kundenseitig war die Anforderung du Ansteuerung über Profinet zu realisieren.
Dafür wurde ein CP343-1 gekauft an dem nun 3x G120x und ein HMI hängen. Zum Test wurde ein Umrichter an die CPU angeschlossen.

Nun hat sich bei der Testinbetriebnahme in der Werkstatt ein kleines Problem ergeben.
Der Umrichter wird über den Siemens Baustein SINA_Speed für die CPU300 angesteuert.
Nachdem der Umrichter über die Schnellinbetriebnahme konfiguriert wurde habe ich den Gerätenamen sowie die IP-Adresse eingestellt. Anschließend wurde das genutzt Telegramm, am Umrichter über das IOP, konfiguriert (Standardtelegramm 20). Den Baustein habe ich dementsprechend erweitert damit die zusätzlichen Emfpangsdaten abgelegt werden können.
Die Kommunikation funktioniert die CPU ist auf grün und alle konfigurierten Teilnehmer sind pingbar.

Das Problem, welches sich ergeben hat ist, dass der Sina_Speed Baustein den Fehlercode 8090 erzeugt. Anscheinend gibt es ein Problem beim Schreiben oder Lesen mit dem Befehl DPWR_Dat. Der E/A Bereich wird im Baustein selbst von Int in ein Word geändert, somit sollte dies nicht den Fehler auslösen. Der Testumrichter wurde mit dem Standardtelegramm 20 in der HW-Konfig parametriert. Die belegten Eingänge sowie Ausgänge starten bei 256.
Zum Test habe ich die Structur "sxSendBuf" in eine UDT umgewandelt und anschließend DPWr_Dat übergeben sowie einen Extra DB angelegt in dem nur zwei Wörter stehen und diese anschließend dem DPWR Dat übergeben. Beides hat leider nicht funktioniert.

Im Anhang noch ein paar Screenshots

Der FU meldet nach der Schnellinbetriebnahme den Fehler 7950 Motorpar fehler. Dieser lässt sich allerdings sofort quittieren.


Ich hoffe ihr könnt mir irgendwie bei meinem Problem weiterhelfen oder habt nützliche Tipps.

MFG
 

Anhänge

  • Geräte&Netze.PNG
    Geräte&Netze.PNG
    60,5 KB · Aufrufe: 22
  • HW_G120X.PNG
    HW_G120X.PNG
    69,6 KB · Aufrufe: 22
  • Sina_Speed.PNG
    Sina_Speed.PNG
    25 KB · Aufrufe: 23
Denke das wird nicht funktionieren.
Die SINA_XX Bausteine sind für die Verwendung der CPU internen PN Schnittstelle geschrieben und nicht für die Verwendung mit einer CP 343-1.
 
prinzipell sollten die Ansteuerung funktionieren (PNIO_SEND und PNIO_RECV) nur eben nicht die SINA_XXX welcche auf DPWR_DAT und DPRD_DAT aufbauen und den Adressraum der CPU nutzen (nicht den Adressraum der CP)
 
Wenn ich das also Richtig verstehe muss ich die Sende und Empfangsdaten in ein DB schreiben. Anschließend Rufe ich den PNIO_Send auf dort gebe ich als Anfangsadresse 256 an und weise ihm den Sende-DB zu. mit der maximalen Anzahl von 12 Sende Byte. In der HW Konfig darf ich also keine Lücke zwischen den Teilnehmern lassen bei der Adressvergabe oder kann ich den Baustein mehrmals aufrufen und immer wieder eine neue Anfangsadresse wählen? Bei Mode müsste dann 16#00 für den Sende und Emfpangsbaustein stehen?
 
Zurück
Oben