S5 schaltets sich immer in off- Modus!?

A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Hallo,

habe ein Programm im Step geschrieben. Wenn ich es auf die S5 ziehe und diese online schalten will, versetzt diese sich sofort wieder in den offline Modus obwohl der Schater noch auf On steht.

Woran kann das liegen? Bei anderen Programmen passiert das nicht.
Fehler in meinem Programm OB oder so? Bin noc neu in dem Gebiet.
Vielen Dank im Voraus.

Marco
 

sps-concept

Well-known member
Beiträge
2.235
Punkte Reaktionen
249
Offline?

Hallo, kanns sein dass du meinst sie geht in STOP obwohl der Schalter auf RUN steht? Offline und Online kannste nur mit dem PG sein.

Sind alle aufgerufenen Bausteine vorhanden? Ist in AWL geschrieben oder in KOP/FUP? Kannst mir ja das Programm mal schicken

andre.raeppel@sps-concept.de

MfG
André Räppel
 

sps-concept

Well-known member
Beiträge
2.235
Punkte Reaktionen
249
Problem

Hallo Marco,

Hallo,

an und für sich konnt ich erstmal nix finden. Man müsste mal in BSTACK und USTACK schaun. Vielleicht weiss einer von den anderen etwas. Kann es sein dass die S5/100 den Befehl RB nicht mag?

Code:
 U M  0.1
 RB =A   
 RB =B   
 RB =C   
 RB =D   
 RB =E   
 RB =F   
 RB =G


MfG
André Räppel
 

sps-concept

Well-known member
Beiträge
2.235
Punkte Reaktionen
249
Problem

Hallo,

hab grad gelesen dass sich FB&s erst ab AG103 parametrieren lassen. Ich würde vorschlagen, testweise den Aufruf des FB12 zu entfernen. Wer kann dazu Auskunft geben? Das gleiche Spiel hat ja Siemens bei den kleinsten 200er Steuerungen auch gemacht.

MfG
André Räppel
 
OP
A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Hi,

die Hardware ist richtig, von E0.* bis E3.* und von A4.* bis A7.*!
Als erstes habe ich den FB 12 auf dem AG gelöscht. Dann habe ich das Netzwerk 29(Aufruf von FB12) im PB6 gelöscht und das Netzwerk 28 durch BE ergänzt, somit letztes Netzwerk.
Leider schaltet sich die S5 immer noch in Stop.

Dann habe ich im OB1 den Aufruf vom PB6 gelöscht. Also nur noch Aufruf von PB1, PB2, PB3, PB5 und FB10.
Jetzt bleibt auch die S5 im On stehen. Problem nur, dass PB6 notwendig für den Automatikbetrieb ist, da dadurch die Ausgänge angesteuert werden.

Wie bekommt man die Funktion USTACK/BSTACK im STep 5 v3.0?
Ich habe noch das Programm STEP7. Hat das die Funktion und kann ich damit die S5 steuern oder ist das überhaupt nicht möglich?
Gruss

Marco
 
OP
A

Anonymous

Guest
übrigens..

im FB12 habe ich vorerst

RB=A
RB=B etc.

jeweils durch

RU=A etc. ergänzt! Ohne Erfolg!

und dann durch

==A etc. ergänzt! Leider auch ohne Erfolg
 

sps-concept

Well-known member
Beiträge
2.235
Punkte Reaktionen
249
Fehler

Hallo, die CPU 100 erlaubt die Timer nur von T0 - T15. Du müsstest also im PB6 die Timer T100 und T101 ändern, zb in T10 und T11.

Ich muss mal suchen wo ich die V3.0 noch hab. Aber das muss irgendwo in den AG-Funktionen zu finden sein. Nein Step7 ist für die S7 und Step5 ist für die S5.

MfG
André Räppel
 
OP
A

Anonymous

Guest
Zuviel Werbung?
->Hier kostenlos registrieren
Also ich muss wirklich sagen, einfach Klasse deine Hilfe!!!
Am Timer hat es gelegen. Der Automatikbetrieb springt jetzt an!!!

Vielen Vielen Dank!!

Es gibt zwar immer noch ein paar kleine Macken, was sicherlich am Modell selber liegt zwecks Kontakte.. aber das Programm läuft!!!! :D

DANKE!
 

sps-concept

Well-known member
Beiträge
2.235
Punkte Reaktionen
249
Bitte

Bitte bitte, so gerät die S5 wenigstens nich ganz in Vergessenheit. Aber du solltest dich mal informieren wie das mit BSTACK und USTACK funzt in deiner Version. Und auch welche Infos dir darüber zur Verfügung gestellt werden. Gerade bei komplexen Programmen ist der Fehler ohne diese Infos kaum zu finden.

MfG
André Räppel
 
Oben